Como administrador de sistemas hace unas semanas me encontre con un error que fue bastante extraño en la empresa en la web trabajo al administrador el panael de adminitracion de actulizaciones WSUS en Windows server 2012 R2. Y esque mas de 500 equipos de la empresa no aparecian en el panel pero al revisar 4 equipos me doy cuenta que todos estan bien configurados y apuntado a la url del servidor de actulizacion. Despues de una investigacion de mas de una semana me di cuenta que l¡La causa principal era que mi empresa al igual que en muchas otras los equipos se despliegan mediante un clonado mediante Acronis True Image para ahorrar tiempo en los despliegues de equipos. Esto provoca que un ID interno que tiene Windows en el registro para identificar el equipo en Windows Update este igual en todos. Y esto provoca un complicto en el WSUS que hace que estos equipos no sean visibles en el WSUS. Para Solucionarlo hice un script que creaba un nuevo ID comos si se tratara de una instalacion nueva y lo desplegue en todos los equipos mediante una script de inicio en el active directory. Y despues de unos dias para que todos los usuarios reiniciaran los equipos. Aparecieron todos esos equipos en el panel de WSUS . !!Solucionado!!

Descargar script : Google drive

Codigo Fuente del script

net stop wuauserv

REG DELETE “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate” /v AccountDomainSid /f

REG DELETE “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate” /v PingID /f

REG DELETE “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate” /v SusClientId /f

net start wuauserv\r\nwuauclt /resetauthorization /detectnow

Share This